Subscribe for updates
New York Exchange internet access unavailable
Incident Report for LMAX
Resolved
Service has been restored to normal.
Posted May 22, 2020 - 09:42 BST
Update
Customers will see increased latency to New York Professional until this incident is fully resolved.
Posted May 22, 2020 - 06:00 BST
Monitoring
Service has been restored, there was a loss of internet access. We are monitoring.
Posted May 22, 2020 - 04:59 BST
Investigating
We are currently investigating this issue.
Posted May 22, 2020 - 04:39 BST