Subscribe for updates
Issues with LMAX Live Chat
Incident Report for LMAX
Resolved
This incident is now resolved.
Posted May 10, 2022 - 11:08 BST
Investigating
The live chat feature at https://www.lmax.com/global is currently experiencing issues. We are investigating the issue. For any inquiries please contact us via info@lmax.com or call our service desk: +44 20 3192 2555
Posted May 10, 2022 - 06:09 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).