Automated deposits and withdrawals
Incident Report for LMAX
Resolved
This has been resolved, payments were not actually failing there was just a rate limit being enforced
Posted 3 months ago. May 23, 2019 - 04:30 BST
Investigating
We are aware that automated payments are not working, we are raising this with our provider.
Posted 3 months ago. May 23, 2019 - 03:10 BST
This incident affected: LMAX Digital (Payments).