Card Withdrawals are currently unavailable
Incident Report for LMAX
Resolved
Card withdrawals are now back up and available
Posted Apr 06, 2020 - 17:44 BST
Identified
The issue has been identified and we are currently looking into it.
Posted Apr 02, 2020 - 18:38 BST
This incident affected: LMAX Global (Payments).