Subscribe for updates

Internet Connectivity problem

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 19:47 GMT

Monitoring

We have recorded impact on the internet based services in London between 18:36 and 18:46 DST. We are currently monitoring the situation.
Posted Feb 20, 2026 - 19:17 GMT

Investigating

We are investigating incident related to internet connectivity.
Posted Feb 20, 2026 - 18:51 GMT