Subscribe for updates

UAT Maintenance

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 11:46 GMT

Investigating

We will be undergoing scheduled maintenance during this time.
Posted Mar 05, 2026 - 09:52 GMT
This incident affected: LMAX Test Environment (LMAX Exchange UAT).