Subscribe for updates
Card payments returning an error
Incident Report for LMAX
Resolved
Card payments are now available
Posted Jun 27, 2022 - 07:09 BST
Identified
We are aware of errors when processing card payments, we are preparing a fix for the issue.
Posted Jun 27, 2022 - 05:37 BST