Subscribe for updates

LMAX Global: Crypto Deposits in Broker

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 16:06 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 15:54 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2026 - 15:23 BST

Investigating

We are currently investigating the issue where Crypto deposits are not showing full ledger information for Broker Clients.
Posted Apr 29, 2026 - 14:25 BST
This incident affected: LMAX Global (Payments).