Subscribe for updates
Internet facing service outage
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 16:41 BST
Monitoring
We are aware of an outage to Broker services between 13:12:34 and 13:25:42 (UTC). We had a load balancer failure that left the services in an inconsistent state. Service is now restored and stable.
Posted Jul 30, 2020 - 14:52 BST
This incident affected: LMAX Digital (Order Entry, Market Data, Trading Portal (GUI), Trade Reporting, Payments, Mobile Trading Apps).