Subscribe for updates
London Digital Trading Issue
Incident Report for LMAX
Resolved
We have carried out further investigation and consider Order entry to be stable.
Posted Jul 07, 2020 - 00:45 BST
Monitoring
We are aware of an issue with London Digital that affected trading between approximately 23:06 and 23:16, a fix has been put in place to restore trading, and a further work is ongoing to resolve the issue completely.
Posted Jul 06, 2020 - 23:51 BST
This incident affected: LMAX Digital (Order Entry).