Subscribe for updates
An interruption to services in New York Professional.
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 09:29 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2024 - 15:58 GMT
Investigating
Between 13:33:30 and 13:34:30 UTC there was an infrastructure related issue in New York exchange.

During this time clients may have had orders delayed, not acknowledged, or sessions disconnected.

All services are now operating as expected, and support staff are investigating.
Posted Mar 08, 2024 - 14:17 GMT
This incident affected: LMAX Exchange New York (NY4) (Market Data).