Subscribe for updates

Issue with Crypto Deposits on LMAX Digital

Incident Report for LMAX

Resolved

this incident has now been resolved.
Posted Jun 20, 2025 - 15:35 BST

Investigating

We are currently investigating the issue
Posted Jun 20, 2025 - 14:41 BST
This incident affected: LMAX Digital (Payments).