Subscribe for updates

LMAX Global Trading platform down

Incident Report for LMAX

Resolved

Please note this incident is now resolved. For further queries, please do hesitate to contact our LMAX Client Services team via info@lmax.com or via +44 20 3192 2555.
Posted Nov 18, 2025 - 12:59 GMT

Investigating

we are currently investigating the issue. Should have you have any issues logging in please do not hesitate to contact our LMAX Client Services team.
Posted Nov 18, 2025 - 12:03 GMT
This incident affected: LMAX Global (Trading Portal (GUI)).