Subscribe for updates

DFX Trading Portal is unavailable

Incident Report for LMAX

Resolved

The incident has been resolved as of 14:42 UTC.
Posted Nov 18, 2025 - 14:55 GMT

Identified

Please note that DFX Trading Portal is currently unavailable. Please contact support if you wish to place a trade.
Posted Nov 18, 2025 - 14:12 GMT