Subscribe for updates
LMAX Trade portal not accessible
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 04:06 BST
Update
We are continuing to investigate this issue.
Posted Oct 07, 2020 - 02:25 BST
Investigating
We are currently investigating this issue
Posted Oct 07, 2020 - 02:21 BST
This incident affected: LMAX Global (Order Entry, Market Data, Trading Portal (GUI), MT4) and LMAX Connectivity (LMAX Proximity London (LD4), LMAX Proximity Tokyo (TY3)).