Subscribe for updates

Corporate websites unavailable

Incident Report for LMAX

Resolved

We have restored service to the corporate websites
Posted Sep 30, 2021 - 00:44 BST

Identified

We are aware that our corporate websites under lmax and lmaxdigital are currently unavailable, you can still manage your account and trade via the respective trading interfaces provided on the splash pages
Posted Sep 30, 2021 - 00:23 BST