Subscribe for updates

LMAX Perpetual Futures - Pricing Incident

Incident Report for LMAX

Resolved

Services are now restored.
Posted May 22, 2026 - 10:18 BST

Update

We are currently investigating alternative solutions to restore service.
Posted May 22, 2026 - 09:11 BST

Investigating

We are investigating market data related incident that has started at 06:09 UTC
Posted May 22, 2026 - 07:49 BST
This incident affected: LMAX Global Perpetual Futures (Market Data).