Subscribe for updates
MT4 Retail intermittent issue
Incident Report for LMAX
Resolved
The incident has been resolved
Posted Jul 19, 2024 - 10:04 BST
Monitoring
We have implemented the workaround and are monitoring the incident
Posted Jul 19, 2024 - 09:12 BST
Investigating
We are currently investigating incident impacting MT4 Retail service.
Posted Jul 19, 2024 - 07:13 BST
This incident affected: LMAX Global (MT4).