Subscribe for updates

Online Chat is not available

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted Feb 17, 2021 - 14:54 GMT

Investigating

We are currently investigating the issue.
Posted Feb 17, 2021 - 14:38 GMT
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).