Subscribe for updates
New York Professional
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 14:11 BST
Monitoring
We had an incident affecting Trading and Market data starting at 06:01 UTC that was resolved at 06:29:23 UTC. Please contact support if you require further information regarding any order statuses.
Posted Sep 01, 2023 - 07:03 BST