Subscribe for updates

Delays in external emails sent from lmax.com and lmaxdigital.com

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 07:58 GMT

Update

We are continuing to monitor for any further issues.
Posted Feb 02, 2026 - 15:53 GMT

Monitoring

We have implemented a fix earlier this morning and are gradually recovering external outbound email service.
Posted Feb 02, 2026 - 14:40 GMT

Investigating

We are investigating an incident impacting emails sent from lmax.com and lmaxdigital.com domains to external contacts.
Posted Feb 02, 2026 - 12:49 GMT
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).