Subscribe for updates
LMAX Live chat unavailable on website
Incident Report for LMAX
Resolved
This incident has now been resolved
Posted Jul 08, 2024 - 22:03 BST
Investigating
We are currently investigating the issue with Live Chat. For urgent queries, please contact us via phone on + 44 20 3192 2555
Posted Jul 08, 2024 - 21:14 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).