Subscribe for updates

LMAX SWAPS X-Bridge Related incident

Incident Report for LMAX

Resolved

This incident has been resolved.
Posted May 18, 2026 - 12:16 BST

Monitoring

A fix has been successfully implemented and service is restored. We are currently monitoring the system.
Posted May 18, 2026 - 10:51 BST

Investigating

We are currently investigating the issue.
Front End application is not affected by this incident.
More updates to follow shortly.
Posted May 18, 2026 - 10:07 BST