LMAX NZ website not accesible
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 19, 2019 - 10:58 BST
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 19, 2019 - 07:25 BST
Investigating
Please note that our LMAX NZ CN website is currently not accessible and our teams are investigating this.
Posted about 1 month ago. Jul 19, 2019 - 07:24 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).