Subscribe for updates
Online chat not available
Incident Report for LMAX
Resolved
The online chat is working now.
Posted Sep 30, 2021 - 06:10 BST
Identified
We are aware that live chat is not available on www.lmax.com/global if you require assistance please call +44 203 1922555 or email info@lmax.com
Posted Sep 30, 2021 - 01:54 BST