Subscribe for updates
Delayed email delivery
Incident Report for LMAX
Resolved
The upstream provider has resolved their email delivery issues.
Posted Nov 29, 2018 - 11:00 GMT
Identified
Issues with upstream provider is delaying email delivery to LMAX client services. Clients with urgent queries to please contact LMAX Global on +44 20 3192 2555 / LMAX Digital on +44 33 3700 4096.
Posted Nov 26, 2018 - 13:03 GMT
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).