lmax.com website not available
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 09, 2019 - 17:21 BST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 09, 2019 - 17:20 BST
Identified
We have identified a change that has affected www.lmax.com and www.lmax.com/blog sites.
Posted 2 months ago. Jul 09, 2019 - 17:19 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).