LMAX Client Portal unable to change new password
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 07:39 BST
Investigating
We are currently investigating this issue.
Posted Oct 24, 2019 - 05:30 BST
This incident affected: LMAX Global (Trading Portal (GUI)).