LMAX NZ website not accesible
Incident Report for LMAX
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 13:10 BST
Investigating
Please note that our LMAX NZ website is currently not accessible and our teams are investigating this.
Posted about 1 month ago. Jul 18, 2019 - 05:02 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).