Live chat currently unavailable
Incident Report for LMAX
Resolved
Our live chat is now back up and running - the issue has now been resolved.
Posted 3 months ago. Jun 06, 2019 - 13:28 BST
Investigating
We are currently experiencing issues with our live chat and are investigating the issue.
Posted 3 months ago. Jun 06, 2019 - 11:31 BST
This incident affected: LMAX Global (Communications (Phones, Emails, Live Chat)).